Internet does not work via bluetooth, Samsung Gear S2

Hello everybody.
Internet does not work via bluetooth. All privileges set. Through the WIFI works but does not work via bluetooth. Please help what might be the problem.
Thank you.


7 Replies
daniel kim


As far as I know, wifi access is not possbile while Gear S2 is connected to phone via bluetooth. then you need to communicate with phone to access internet through SAP.

I would suggest you to visit this link as well. Gear S2 related document is available in this site.




Could you please share you code sample?

What request are you using? XMLHttpRequest ot WebSocket?

F.e. you can send xmlhttprequest or use audio/video tag with external content through mobile wifi but you cannot use websocket.

Eugene Morenko

I'm using webkit.

tinyweb->web.evas = evas_object_evas_get(tinyweb->web.scroller);
tinyweb->web.ewk = ewk_view_add(tinyweb->web.evas);


you should set proxy when the device is using network via bluetooth.

check connection APIs to get the proxy settings.


Eugene Morenko

please give an example


the code is depends on your implementation and wht you are going to do, so I can give you some hints only.

0. you don't need SAP command to use internet. internet can be accessed via web proxy without any other special procedure in BT mode.

1. to get proxy setting or connection info, you can use connection APIs of Tizen SDK.  check SDK help.

2. if you are using internet via curl, you can use curl_easy_setopt() to set the proxy setting for your internet connection.

3. if you are using internet via socket, you should manage web proxy (a.k.a http tunnelling or something like that). you can google it and will get plenty of examples.

good luck.

Ivan Ramanenka

I found the answer. You need to check you phone and allow 'Blouetooth tethering' in Access Point Settings.

Tested on Gear S3 connected over bluetooth to my Nexus 5x (WiFi off)