Emulator “Device initialization failed” with macOS and Tizen 2.x Web app development issues


I’m having hard time getting started with the Web application development for Tizen TVs (OS 2.3 and 2.4). I installed the latest version of Tizen Studio (2.4).

When I try to launch the emulator with default “tv-samsung-4.0-x86” device configuration (CPU VT and GPU is set to ON) I get the following error:

“-device vigs,backend=gl,wsi=vigs_wsi: Device initialization failed”

Could someone please help with this issue? Could not find any working solution for this problem.

My system:
macOS High Sierra
MacBook Pro (15-inch, 2017)
2,9 GHz Intel Core i7
16 GB 2133 MHz LPDDR3
Radeon Pro 560 4 GB
Intel HD Graphics 630 1536 MB

Other issues and concerns

  • What version of Tizen Studio I should use for developing Web applications for these quite new Samsung Digital Signage screen such as PM32F? These have Tizen 2.x if I’m correct.
  • Is Tizen 2.x Web app compatible with Tizen 3.x-4.x versions? So if I build my app that is targetted for Tizen 2.3, should it run also with the latest Tizen versions such as 4.0?

Note: I also added this post to Samsung Developer forums but perhaps this questions belongs more here.


18 Replies
André Reus

Hi Mikael Linko
Need some more info also like 

* List of packages you have installed from Package Manager ( from both Main SDK and Extension SDK tabs)

* TV emulator OS version ( I am assuming 4.0)

* App API version 

* Did you find any public documentation for Signage app development? 

If you develop app with 2.X, it should run on 3.X or 4.X. 

Mikael Linko

List of installed packages (everything should be up to date):

Main SDK:
Tizen SDK tools (Baseline SDK (.NET CLI, Certificate Manager, Emulator manager), Web CLI, Web IDE )

Extension SDK:
TV Extensions-4.0 (Emulator, Web app. development, Samsung Certificate Extensions)
(So I assume that TV emulator OS version is 4.0 then)

I did not find any other development information in addition to .

I am not able to run any app on the emulator since the emulator does not even start because of the “-device vigs,backend=gl,wsi=vigs_wsi: Device initialization failed” error. 

Would be nice to hear if someone has been able to run this emulator on similar macOS system with two graphics card. 



André Reus

would you please delete the emulator and create again ?

Mikael Linko

Yes, I tried but still get the same error. I have also tried to reinstall the tizen studio and all the packages again. 


André Reus

What is your Java version ? Java version mismatch may create problem .. please let us know the java version 

Mikael Linko

I had to downgrade my Java version to 1.8.0_151 because I had problems with newer Java versions. 

p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 11.0px Menlo; color: #000000; background-color: #ffffff} span.s1 {font-variant-ligatures: no-common-ligatures; color: #34bc26} span.s2 {font-variant-ligatures: no-common-ligatures; color: #33bbc8} span.s3 {font-variant-ligatures: no-common-ligatures}

java -version

java version "1.8.0_151"

Java(TM) SE Runtime Environment (build 1.8.0_151-b12)

Java HotSpot(TM) 64-Bit Server VM (build 25.151-b12, mixed mode)



André Reus

So, your problem is solved now by downgrading java version...right? 

Mikael Linko

No the problem is not solved. It still exisists. Downgrading Java version only solved some problems to make it even possible to launch the Tizen Studio and Tizen IDE. 

André Reus

But in previous comment, you mentioned that you have installed all the required packages and emulator. You were facing problem to launch the emulator ... but now you are saying java version solved your problem to launch the ide ! please make it clear with screenshot 

Mikael Linko

André Reus

I can't see anyting from your comment ... please attach image or give imgur link here. 

Mikael Linko

Hopefully this image works.

André Reus

To use the TV emulator:

Mikael Linko


My CPU supports VT-x and it is listed in my cpu features ( "sysctl -a | grep machdep.cpu.features" lists VMX that means CPU supports Intel VT-x).

I found other problem from the forums with similar issue

However, I have not been able to fix this issue.


André Reus

May be this is bug... you can create bug issue here

André Reus

Hi Mikael Linko

Could you please try to create and open Mobile/Wearable emulator on your system ? please let me know the status after trying ....


Mikael Linko

I tried and got the same error.

Changseok Oh

Could you please try to reinstall IntelHaxm with below link?

If you are using High Sierra, the installed haxm can not support this version.