Error when deploying app to Tizen 2018

We have been deploying package to Tizen TVs without problems. To address some issues specific to the 2018 models, we're trying to deploy an app to this Tizen TV through TIzen Studio 2.4.

Model Code: UN55NU7100
Software Version: T-KTM2LAKUC-1103.4
Sub-micro Version: T-KTM2INTV-1003

Platform: tv-4.0

So far, we have no luck in deploying to this TV. The console message shows this error:

[Installing the package...]
wascmd cannot working in released image
    An exception occurred
(Installing the package... > fail)
An exception occurred
Unexpected stop progress...
(3.723 sec)

The log have this message:

[time][ERROR] - Return Code:1010)Tizen Web Application install failed.

We have tried on Mac and Windows, updating SDK and fresh install of Tizen Studio. Connection to TV is working and certificate can be uploaded to the TV. Anybody has any clue?

Thanks in advance.


10 Replies
Armaan-Ul- Islam

In Ideal Scenario:

# A tizen application Installation on a real device requires 'Samsung Certificate'.


But may be due to some error/bug in IDE recently, It's not working that way. As an workaround you can create a 'Tizen Certificate' (Public) for now and build/sign the app package using that certificate. Then deploy the app on TV device. Share your feedback on this post.

And Here's a Relevant Post on this Forum.


Thanks Armaan-Ul- Islam. Are you able to upload the public certificate without DUID? I tried that by using "Permit to install applications" in device manager but it returned error as if no certificate is selected.

I wonder if this is the same issue as I don't get "was_install_app return WAS_TRUE" when I deploy to real device. Or maybe you only get that message when deploying to emulator?

Armaan-Ul- Islam

You're welcome.

The Suggestion I shared for 'Trial & Error' was to Create and Select Tizen Certificate, Clean & build app and run on device. Skip the 'Permit to install applications' part.


The Issue I mentioned isn't same, just 'relevant'.


I see. Thanks! Looks like my issue is related to firmware.


Hi.Tell me why I can't install even the basic applications that are in tizen studio to test the Studio with the TV on my TV.TV Samsung UE55NU8070.Tizen Studio 2.4 . There is a coordination of the TV with the Studio.I tried to receive certificates both from Tizen and from Samsung . But still the same error by 58 % .And no matter what project I try,it's all the same.In the Studio in the simulator projects run, and check the work on the TV I can not.

Maksim Mazanik

I have same TV and same problem with installing. Do you have new information to solve this problem?

виктор Коваленко

That's what they said on Samsung


Dear Developer,

We are aware of this issue on 2018 models. We already forwarded this to our engineers and as soon as we get more information we will inform all developres about solution. We are really sorry about situation.

We will contact you as soon as posible with the solution. 

Kind Regards,

Samsung Team

Brock Fisher

Any update on this? This is really causing some problems for us. we have no older model Samsung to test with. We bough brand new models. Our app runs on the emulater, can we still submit this to Samsung for approval in the samsung app store? 

Armaan-Ul- Islam

Samsung TV Seller Office also provides 1:1 Q&A Support.

Samsung Apps TV Seller Office>Support > 1:1 QA

You might knock themfor your query.

Armaan-Ul- Islam

Deploying App to TV Emulator signed with 'Tizen Certificate' worked fine for my case. I would suggest that, you may post your issue on Samsung TV Forum

Developers on the specific domain may share their experiences with you there.